CCIE Bootcamp: MPLS

Hari ke-5 saya akan menulis mengenai MPLS dasar mulai dari OSPF, LDP, BGP, MP-BGP dan PE-CE routing menggunakan RIP dan EIGRP. Mari kita mulai dari konfigurasi alamat IP.

Konfigurasi PE1:

interface Loopback0
 ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.10.1 255.255.255.252
!
router ospf 1
 log-adjacency-changes
 network 10.10.10.1 0.0.0.0 area 0
 network 192.168.10.1 0.0.0.0 area 0

 

Konfigurasi P:

interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.10.2 255.255.255.252
!
interface FastEthernet0/1
 ip address 192.168.20.1 255.255.255.252
!
router ospf 1
 network 10.10.10.10 0.0.0.0 area 0
 network 192.168.10.2 0.0.0.0 area 0
 network 192.168.20.1 0.0.0.0 area 0

 

Konfigurasi PE2:

interface Loopback0
 ip address 10.10.10.2 255.255.255.252
!
interface FastEthernet0/0
 ip address 192.168.20.2 255.255.255.252
!
router ospf 1
 network 10.10.10.2 0.0.0.0 area 0
 network 192.168.20.2 0.0.0.0 area 0

 

Konfigurasi di CE-A1:

interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Serial0/0
 ip address 192.168.0.2 255.255.255.252

 

Konfigurasi di CE-A2

interface Loopback0
 ip address 10.0.0.2 255.255.255.255
!
interface Serial0/0
 ip address 192.168.0.6 255.255.255.252

 

Konfigurasi di CE-B1

interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Serial0/0
 ip address 192.168.0.2 255.255.255.252

 

Konfigurasi di CE-B2

interface Loopback0
 ip address 10.0.0.2 255.255.255.255
!
interface Serial0/0
 ip address 192.168.0.6 255.255.255.252

 

Setelah konfigurasi dasar IP dan OSPF selesai kita lanjut dengan menjalankan Label Distribution Protocol (LDP).

Konfigurasi PE1:

mpls ldp router-id Loopback0
!
mpls ip
!
interface FastEthernet0/0
 mpls ip

 

Konfigurasi P:

mpls ldp router-id Loopback0
!
mpls ip
!
interface FastEthernet0/0
 mpls ip
!
interface FastEthernet0/1
 mpls ip

 

Konfigurasi PE2:

mpls ldp router-id Loopback0
!
mpls ip
!
interface FastEthernet0/0
 mpls ip

 

Kita bisa mengecek status neighbor LDP dengan perintah show mpls ldp neighbor.

PE1#sh mpls ldp neighbor
 Peer LDP Ident: 10.10.10.10:0; Local LDP Ident 10.10.10.1:0
 TCP connection: 10.10.10.10.25695 - 10.10.10.1.646
 State: Oper; Msgs sent/rcvd: 8/8; Downstream
 Up time: 00:00:20
 LDP discovery sources:
 FastEthernet0/0, Src IP addr: 192.168.10.2
 Addresses bound to peer LDP Ident:
 192.168.10.2 10.10.10.10 192.168.20.1
P#sh mpls ldp neighbor
 Peer LDP Ident: 10.10.10.1:0; Local LDP Ident 10.10.10.10:0
 TCP connection: 10.10.10.1.646 - 10.10.10.10.25695
 State: Oper; Msgs sent/rcvd: 8/9; Downstream
 Up time: 00:00:54
 LDP discovery sources:
 FastEthernet0/0, Src IP addr: 192.168.10.1
 Addresses bound to peer LDP Ident:
 192.168.10.1 10.10.10.1
 Peer LDP Ident: 10.10.10.2:0; Local LDP Ident 10.10.10.10:0
 TCP connection: 10.10.10.2.646 - 10.10.10.10.25231
 State: Oper; Msgs sent/rcvd: 9/9; Downstream
 Up time: 00:00:54
 LDP discovery sources:
 FastEthernet0/1, Src IP addr: 192.168.20.2
 Addresses bound to peer LDP Ident:
 192.168.20.2 10.10.10.2
PE2#sh mpls ldp neighbor
 Peer LDP Ident: 10.10.10.10:0; Local LDP Ident 10.10.10.2:0
 TCP connection: 10.10.10.10.25231 - 10.10.10.2.646
 State: Oper; Msgs sent/rcvd: 9/9; Downstream
 Up time: 00:01:06
 LDP discovery sources:
 FastEthernet0/0, Src IP addr: 192.168.20.1
 Addresses bound to peer LDP Ident:
 192.168.10.2 10.10.10.10 192.168.20.1

 

Sampai di sini tidak ada penambahan konfigurasi untuk router P. Sekarang mari kita konfigurasi VRF untuk site A dan B.

Di PE1:

ip vrf B1
 rd 65000:2
 route-target export 65000:2
 route-target import 65000:2

 

Di PE2:

ip vrf A2
 rd 65000:1
 route-target export 65000:1
 route-target import 65000:1
!
ip vrf B2
 rd 65000:2
 route-target export 65000:2
 route-target import 65000:2

 

Setelah itu kita konfigurasi BGP dan MP-BGP.

BGP di PE1:

router bgp 65000
 neighbor 10.10.10.2 remote-as 65000
 neighbor 10.10.10.2 update-source Loopback0

 

MP-BGP di PE1:

router bgp 65000
 !
 address-family vpnv4
 neighbor 10.10.10.2 activate
 neighbor 10.10.10.2 send-community extended

 

BGP di PE2:

router bgp 65000
 neighbor 10.10.10.1 remote-as 65000
 neighbor 10.10.10.1 update-source Loopback0

 

MP-BGP di PE1:

router bgp 65000
 !
 address-family vpnv4
 neighbor 10.10.10.1 activate
 neighbor 10.10.10.1 send-community extended

 

Mari kita cek status neighbor untuk BGP dan MP-BGP.

BGP

PE1#sh ip bgp summary
BGP router identifier 10.10.10.1, local AS number 65000
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.2 4 65000 19 19 1 0 0 00:14:25 0
PE2#sh ip bgp summary
BGP router identifier 10.10.10.2, local AS number 65000
BGP table version is 1, main routing table version 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.1 4 65000 19 19 1 0 0 00:14:41 0

 

MP-BGP

PE1#sh ip bgp vpnv4 all summary
BGP router identifier 10.10.10.1, local AS number 65000
BGP table version is 9, main routing table version 9
4 network entries using 560 bytes of memory
4 path entries using 272 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
1 BGP extended community entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1260 total bytes of memory
BGP activity 4/0 prefixes, 4/0 paths, scan interval 15 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.2 4 65000 20 20 9 0 0 00:15:05 2
PE2#sh ip bgp vpnv4 all summary
BGP router identifier 10.10.10.2, local AS number 65000
BGP table version is 9, main routing table version 9
4 network entries using 560 bytes of memory
4 path entries using 272 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
1 BGP extended community entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1260 total bytes of memory
BGP activity 4/0 prefixes, 4/0 paths, scan interval 15 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.10.10.1 4 65000 20 20 9 0 0 00:15:33 2

 

Sampai di sini kita sudah siap untuk menambahkan customer A dan B ke dalam MPLS. Pertama kita akan menambahkan customer A dengan menggunakan routing protocol RIP.

Konfigurasi di PE1:

ip vrf A1
 rd 65000:1
 route-target export 65000:1
 route-target import 65000:1
!
interface Serial0/0
 ip vrf forwarding A1
 ip address 192.168.0.1 255.255.255.252
!
router rip
 version 2
 !
 address-family ipv4 vrf A1
 redistribute bgp 65000 metric transparent
 network 192.168.0.0
 no auto-summary
 version 2
!
router bgp 65000
 !
 address-family ipv4 vrf A1
 redistribute rip

 

Konfigurasi di PE2:

ip vrf A2
 rd 65000:1
 route-target export 65000:1
 route-target import 65000:1
!
interface Serial0/0
 ip vrf forwarding A2
 ip address 192.168.0.5 255.255.255.252
!
router rip
 version 2
 !
 address-family ipv4 vrf A2
 redistribute bgp 65000 metric transparent
 network 192.168.0.0
 no auto-summary
 version 2
!
router bgp 65000
 !
 address-family ipv4 vrf A2
 redistribute rip

 

Konfigurasi di CE-A1

router rip
 version 2
 network 0.0.0.0
 no auto-summary

 

Konfigurasi di CE-A2

router rip
 version 2
 network 0.0.0.0
 no auto-summary

 

Mari kita cek tabel routing di CE-A1 dan CE-A2.

CE-A1#sh ip route rip
 10.0.0.0/32 is subnetted, 2 subnets
R 10.0.0.2 [120/2] via 192.168.0.1, 00:00:15, Serial0/0
 192.168.0.0/30 is subnetted, 2 subnets
R 192.168.0.4 [120/1] via 192.168.0.1, 00:00:15, Serial0/0
CE-A1#ping 10.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/16/24 ms
CE-A2#sh ip route rip
 10.0.0.0/32 is subnetted, 2 subnets
R 10.0.0.1 [120/2] via 192.168.0.5, 00:00:25, Serial0/0
 192.168.0.0/30 is subnetted, 2 subnets
R 192.168.0.0 [120/1] via 192.168.0.5, 00:00:25, Serial0/0
CE-A2#ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/16 ms

 

Selanjutnya kita akan menambahkan customer B dengan routing protocol EIGRP

Konfigurasi di PE1:

ip vrf B1
 rd 65000:2
 route-target export 65000:2
 route-target import 65000:2
!
interface Serial0/1
 ip vrf forwarding B1
 ip address 192.168.0.1 255.255.255.252
!
router eigrp 65000
 !
 address-family ipv4 vrf B1
 redistribute bgp 65000 metric 1 1 1 1 1
 network 192.168.0.0
 no auto-summary
 autonomous-system 100
!
router bgp 65000
 !
 address-family ipv4 vrf B1
 redistribute eigrp 100

 

Konfigurasi di PE2:

ip vrf B2
 rd 65000:2
 route-target export 65000:2
 route-target import 65000:2
!
interface Serial0/1
 ip vrf forwarding B2
 ip address 192.168.0.1 255.255.255.252
!
router eigrp 65000
 !
 address-family ipv4 vrf B2
 redistribute bgp 65000 metric 1 1 1 1 1
 network 192.168.0.0
 no auto-summary
 autonomous-system 100
!
router bgp 65000
 !
 address-family ipv4 vrf B2
 redistribute eigrp 100

 

Konfigurasi di CE-B1

router eigrp 100
 network 10.0.0.0
 network 192.168.0.0
 no auto-summary

 

Konfigurasi di CE-B2

router eigrp 100
 network 10.0.0.0
 network 192.168.0.0
 no auto-summary

 

Kita cek lagi tabel routing di CE-B1 dan CE-B2.

CE-B1#sh ip route eigrp
 10.0.0.0/32 is subnetted, 2 subnets
D 10.0.0.2 [90/2809856] via 192.168.0.1, 00:06:56, Serial0/0
 192.168.0.0/30 is subnetted, 2 subnets
D 192.168.0.4 [90/2681856] via 192.168.0.1, 00:06:56, Serial0/0
CE-B1#ping 10.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/16 ms
CE-B2#sh ip route eigrp
 10.0.0.0/32 is subnetted, 2 subnets
D 10.0.0.1 [90/2809856] via 192.168.0.5, 00:07:38, Serial0/0
 192.168.0.0/30 is subnetted, 2 subnets
D 192.168.0.0 [90/2681856] via 192.168.0.5, 00:07:38, Serial0/0
CE-B2#ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/13/16 ms

 

Sekarang mari kita menambahkan multicast di B1 dan B2. Kita konfigurasi multicast dengan static RP melewati tunnel GRE.

Konfigurasi B1:

ip multicast-routing
!
interface Loopback0
 ip pim sparse-mode
 ip igmp join-group 239.0.0.1
!
interface Tunnel1
 ip address 12.12.12.1 255.255.255.252
 ip pim sparse-mode
 tunnel source Loopback0
 tunnel destination 10.0.0.2
!
ip pim rp-address 10.0.0.1

 

Konfigurasi B2:

ip multicast-routing
!
interface Loopback0
 ip pim sparse-mode
!
interface Tunnel1
 ip address 12.12.12.2 255.255.255.252
 ip pim sparse-mode
 tunnel source Loopback0
 tunnel destination 10.0.0.1
!
ip pim rp-address 10.0.0.1

 

Mari kita ping IP multicast 239.0.0.1 dari B2

CE-B2#ping 239.0.0.1
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.0.0.1, timeout is 2 seconds:
Reply to request 0 from 12.12.12.1, 16 ms

 

Mari kita lihat juga informasi tentang RP di B2.

CE-B2#sh ip mroute
 IP Multicast Routing Table
 Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
 L - Local, P - Pruned, R - RP-bit set, F - Register flag,
 T - SPT-bit set, J - Join SPT, M - MSDP created entry,
 X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
 U - URD, I - Received Source Specific Host Report,
 Z - Multicast Tunnel, z - MDT-data group sender,
 Y - Joined MDT-data group, y - Sending to MDT-data group
 Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 239.0.0.1), 00:10:07/stopped, RP 10.0.0.1, flags: SPF
 Incoming interface: Null, RPF nbr 0.0.0.0
 Outgoing interface list: Null
(12.12.12.2, 239.0.0.1), 00:03:36/00:02:26, flags: PFT
 Incoming interface: Tunnel1, RPF nbr 0.0.0.0, Registering
 Outgoing interface list: Null
(*, 224.0.1.40), 00:11:37/00:02:35, RP 10.0.0.1, flags: SJCL
 Incoming interface: Null, RPF nbr 0.0.0.0
 Outgoing interface list:
 Loopback0, Forward/Sparse, 00:11:37/00:02:35
 CE-B2#sh ip pim rp mapping
 PIM Group-to-RP Mappings
Group(s): 224.0.0.0/4, Static
 RP: 10.0.0.1 (?)
Advertisements

CCIE Bootcamp: RIP dan EIGRP

Hari ke-2 dibahas tentang RIP dan EIGRP, untuk tulisan blog kali ini saya hanya ambil dua kasus masing-masing satu untuk RIP dan EIGRP.

RIP: Split Horizon
Split horizon adalah suatu metoda untuk menghindari routing loops, mekanismenya dengan menolak mengirim route kembali melalui interface tempat route tersebut diterima. Contohnya apabila route 10.0.0.0/8 diterima melalui interface Fa0/0 maka split horizon tidak akan mengirim kembali route 10.0.0.0/8 tersebut melalui interface Fa0/0

Pada hub and spoke dengan routing RIP, split horizon akan menjadi masalah karena informasi route dari satu spoke tidak akan diteruskan ke spoke yang lain. Solusi untuk mengatasi ini ada dua, yaitu: disable split horizon dan konfigurasi hub sebagai point to point. Kita lihat pada gambar, R1 berfungsi sebagai hub, R2 dan R3 sebagai spoke.

Solusi 1: Disable Split Horizon

Konfigurasi FRSW:

frame-relay switching
!
interface Serial0/0
 description "To R2"
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0/2 102
!
interface Serial0/1
 description "To R3"
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 301 interface Serial0/2 103
!
interface Serial0/2
 description "To R1"
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/0 201
 frame-relay route 103 interface Serial0/1 301

 

Konfigurasi R1:

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.123 multipoint
 ip address 123.123.123.1 255.255.255.0
 frame-relay map ip 123.123.123.3 103 broadcast
 frame-relay map ip 123.123.123.2 102 broadcast
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

 

Konfigurasi R2:

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
 ip address 123.123.123.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 123.123.123.3 201
 frame-relay map ip 123.123.123.1 201 broadcast
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

 

Konfigurasi R3:

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
 ip address 123.123.123.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 123.123.123.2 301
 frame-relay map ip 123.123.123.1 301 broadcast
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

 

Mari kita cek melalui perintah sh ip route rip.

R1#sh ip route rip
     1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R       1.0.0.0/8 [120/2] via 123.123.123.3, 00:02:05, Serial0/0.123
                  [120/2] via 123.123.123.2, 00:01:52, Serial0/0.123
     2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R       2.2.2.2/32 [120/1] via 123.123.123.2, 00:00:24, Serial0/0.123
R       2.0.0.0/8 [120/1] via 123.123.123.2, 00:01:52, Serial0/0.123
     3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R       3.3.3.3/32 [120/1] via 123.123.123.3, 00:00:10, Serial0/0.123
R       3.0.0.0/8 [120/1] via 123.123.123.3, 00:02:05, Serial0/0.123

 

Sepertinya tidak ada masalah pada R1, semua route interface loopback diterima. Selanjutnya kita cek pada R2 dan R3.

R2#sh ip route rip
     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 123.123.123.1, 00:00:08, Serial0/0
R3#sh ip route rip
     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 123.123.123.1, 00:00:06, Serial0/0

 

Kita lihat di sini R2 dan R3 tidak menerima route dari masing-masing interface loopback. Sekarang mari kita disable split horizon di interface multipoint di R1.

R1(config)#int s0/0.123
R1(config-subif)#no ip split-horizon

 

Tunggu sebentar dan cek lagi informasi route di R2 dan R3

R2#sh ip route rip
     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 123.123.123.1, 00:00:03, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
R       3.3.3.3 [120/2] via 123.123.123.3, 00:00:03, Serial0/0

R3#sh ip route rip
     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 123.123.123.1, 00:00:01, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
R       2.2.2.2 [120/2] via 123.123.123.2, 00:00:01, Serial0/0

 

Lalu ping.

R2#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/8 ms

 

Solusi 2: Konfigurasi Hub Sebagai Point to Point

Di sini kita akan mengubah interface multipoint di R1 menjadi point to point. Solusi ini membutuhkan pengubahan alamat IP di semua router.

Konfigurasi R1:

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.2 point-to-point
 ip address 12.12.12.1 255.255.255.0
 frame-relay interface-dlci 102
!
interface Serial0/0.3 point-to-point
 ip address 13.13.13.1 255.255.255.0
 frame-relay interface-dlci 103
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

 

Konfigurasi R2:

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
 ip address 12.12.12.2 255.255.255.0
 encapsulation frame-relay
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

 

Konfigurasi R3:

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
 ip address 13.13.13.3 255.255.255.0
 encapsulation frame-relay
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

 

Mari kita cek.

R1#sh ip route rip
 2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 12.12.12.2, 00:00:16, Serial0/0.2
 3.0.0.0/32 is subnetted, 1 subnets
R 3.3.3.3 [120/1] via 13.13.13.3, 00:00:06, Serial0/0.3
R2#sh ip route rip
 1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 12.12.12.1, 00:00:03, Serial0/0
 3.0.0.0/32 is subnetted, 1 subnets
R 3.3.3.3 [120/2] via 12.12.12.1, 00:00:03, Serial0/0
 13.0.0.0/24 is subnetted, 1 subnets
R 13.13.13.0 [120/1] via 12.12.12.1, 00:00:03, Serial0/0
R3#sh ip route rip
 1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 13.13.13.1, 00:00:24, Serial0/0
 2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/2] via 13.13.13.1, 00:00:24, Serial0/0
 12.0.0.0/24 is subnetted, 1 subnets
R 12.12.12.0 [120/1] via 13.13.13.1, 00:00:24, Serial0/0

 

Dan ping.

R2#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/8 ms

 

EIGRP: Unequal Cost Load Balancing

Load balancing adalah kemampuan untuk mendistribusikan trafik melalui interface yang mempunyai suatu nilai yang sama ke tujuan. Di EIGRP nilai ini dapat diubah dengan mengubah parameter bandwidth dan delay. Mari kita lihat topologi dan konfigurasi berikut.

Konfigurasi R1

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 13.13.13.1 255.255.255.0
!
router eigrp 10
 network 1.1.1.1 0.0.0.0
 network 12.12.12.1 0.0.0.0
 network 13.13.13.1 0.0.0.0
 no auto-summary

 

Konfigurasi R2

int Loopback0
 ip add 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.2 255.255.255.0
!
interface FastEthernet0/1
 ip address 24.24.24.2 255.255.255.0
!
router eigrp 10
 net 12.12.12.2 0.0.0.0
 net 2.2.2.2 0.0.0.0
 net 24.24.24.2 0.0.0.0
 no auto-summary

 

Konfigurasi R3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 13.13.13.3 255.255.255.0
!
interface FastEthernet0/1
 ip address 34.34.34.3 255.255.255.0
!
router eigrp 10
 network 3.3.3.3 0.0.0.0
 network 13.13.13.3 0.0.0.0
 network 34.34.34.3 0.0.0.0
 no auto-summary

 

Konfigurasi R4

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 24.24.24.4 255.255.255.0
!
interface FastEthernet0/1
 ip address 34.34.34.4 255.255.255.0
!
router eigrp 10
 network 4.4.4.4 0.0.0.0
 network 24.24.24.4 0.0.0.0
 network 34.34.34.4 0.0.0.0
 no auto-summary

 

Apabila tidak ada perubahan apapun maka dari R1 menuju ke loopback R4 akan mempunyai dua jalur melalui R2 dan R3

R1#sh ip route eigrp
 34.0.0.0/24 is subnetted, 1 subnets
D 34.34.34.0 [90/307200] via 13.13.13.3, 00:00:22, FastEthernet0/1
 2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 12.12.12.2, 00:00:15, FastEthernet0/0
 3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 13.13.13.3, 00:00:14, FastEthernet0/1
 4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/435200] via 13.13.13.3, 00:00:13, FastEthernet0/1
 [90/435200] via 12.12.12.2, 00:00:13, FastEthernet0/0
 24.0.0.0/24 is subnetted, 1 subnets
D 24.24.24.0 [90/307200] via 12.12.12.2, 00:00:13, FastEthernet0/0
R1#sh ip route 4.4.4.4
Routing entry for 4.4.4.4/32
 Known via "eigrp 10", distance 90, metric 435200, type internal
 Redistributing via eigrp 10
 Last update from 12.12.12.2 on FastEthernet0/0, 00:03:57 ago
 Routing Descriptor Blocks:
 * 13.13.13.3, from 13.13.13.3, 00:03:57 ago, via FastEthernet0/1
 Route metric is 435200, traffic share count is 1
 Total delay is 7000 microseconds, minimum bandwidth is 10000 Kbit
 Reliability 255/255, minimum MTU 1500 bytes
 Loading 1/255, Hops 2
 12.12.12.2, from 12.12.12.2, 00:03:57 ago, via FastEthernet0/0
 Route metric is 435200, traffic share count is 1
 Total delay is 7000 microseconds, minimum bandwidth is 10000 Kbit
 Reliability 255/255, minimum MTU 1500 bytes
 Loading 1/255, Hops 2

 

Dalam hal ini yang terjadi adalah equal cost load balancing. Sekarang kita akan membagi trafik ke R4 dengan perbandingan 2:1, untuk setiap 2 paket dari R1 melewati R2 maka ada satu paket dari R1 melewati R3. Parameter yang akan kita ubah adalah bandwidth (K1) dan delay (K3) dengan nilai K lain adalah 0.

Bandwidth = 10^7 / minimum Bw kbps
Delay = delay in tens of microseconds
Metric = 256 x (Bandwidth + Delay)

Kalau kita membutuhkan perbandingan 2:1, maka kita harus mempunyai metric menuju R3 dua kali lebih besar yaitu 870400. Dengan rumus di atas maka akan kita dapatkan minimum Bw = 3703, silakan hitung sendiri darimana dapatnya 😀 Nilai ini kita masukan di interface Fa0/1 dengan perintah bandwidth.

R1(config)#int f0/1
 R1(config-if)#bandwidth 3703
 R1(config-if)#end

 

Kita hapus tabel routing

R1#clear ip route *

 

Lalu kita lihat nilai metric menuju R4

R1#sh ip eigrp topology 4.4.4.4/32
IP-EIGRP (AS 10): Topology entry for 4.4.4.4/32
 State is Passive, Query origin flag is 1, 1 Successor(s), FD is 435200
 Routing Descriptor Blocks:
 12.12.12.2 (FastEthernet0/0), from 12.12.12.2, Send flag is 0x0
 Composite metric is (435200/409600), Route is Internal
 Vector metric:
 Minimum bandwidth is 10000 Kbit
 Total delay is 7000 microseconds
 Reliability is 255/255
 Load is 1/255
 Minimum MTU is 1500
 Hop count is 2
 13.13.13.3 (FastEthernet0/1), from 13.13.13.3, Send flag is 0x0
 Composite metric is (870400/409600), Route is Internal
 Vector metric:
 Minimum bandwidth is 3703 Kbit
 Total delay is 7000 microseconds
 Reliability is 255/255
 Load is 1/255
 Minimum MTU is 1500
 Hop count is 2

 

Sekarang kita tambahkan perintah variance di EIGRP dengan nilai 2 (untuk perbandingan 2:1)

R1(config)#router eigrp 10
R1(config-router)#var
R1(config-router)#variance 2

 

Mari kita lihat lagi tabel routing untuk 4.4.4.4

R1#sh ip route 4.4.4.4
Routing entry for 4.4.4.4/32
 Known via "eigrp 10", distance 90, metric 435200, type internal
 Redistributing via eigrp 10
 Last update from 13.13.13.3 on FastEthernet0/1, 00:02:26 ago
 Routing Descriptor Blocks:
 13.13.13.3, from 13.13.13.3, 00:02:26 ago, via FastEthernet0/1
 Route metric is 870400, traffic share count is 1
 Total delay is 7000 microseconds, minimum bandwidth is 3703 Kbit
 Reliability 255/255, minimum MTU 1500 bytes
 Loading 1/255, Hops 2
 * 12.12.12.2, from 12.12.12.2, 00:02:26 ago, via FastEthernet0/0
 Route metric is 435200, traffic share count is 2
 Total delay is 7000 microseconds, minimum bandwidth is 10000 Kbit
 Reliability 255/255, minimum MTU 1500 bytes
 Loading 1/255, Hops 2

 

Di sini kita lihat sekarang trafik terbagi menjadi 2:1 untuk R2:R3.