CCIE Bootcamp: OSPF dan IPv6

Hari ke-3 dibahas tentang OSPF dan IPv6, untuk materi ini akan saya gabungkan menjadi satu topologi. Saya akan menjalankan OSPF dengan IPv4 dan IPv6 pada topologi hub and spoke di frame relay. IPv4 akan menggunakan tipe broadcast sedangkan IPv6 akan menggunakan tipe non-broadcast.

Konfigurasi Frame Relay Switch sama dengan yang digunakan pada lab RIP di tulisan sebelumnya.

 

OSPF dengan IPv4

Konfigurasi R1:

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 123.123.123.1 255.255.255.0
 encapsulation frame-relay
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0

 

Konfigurasi R2:

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
 ip address 123.123.123.2 255.255.255.0
 encapsulation frame-relay
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0

 

Konfigurasi R3:

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
 ip address 123.123.123.3 255.255.255.0
 encapsulation frame-relay
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0

 

Dengan konfigurasi awal ini mari kita lihat proses OSPF-nya apakah sudah ada koneksi dengan neighbor.

R1#sh ip ospf neighbor
R1#

 

Ternyata belum ada neighbor, mari kita lihat konfigurasi OSPF untuk interface s0/0.

R1#sh ip ospf interface s0/0
Serial0/0 is up, line protocol is up
 Internet Address 123.123.123.1/24, Area 0
 Process ID 1, Router ID 1.1.1.1, Network Type NON_BROADCAST, Cost: 64
 Transmit Delay is 1 sec, State DR, Priority 1
 Designated Router (ID) 1.1.1.1, Interface address 123.123.123.1
 No backup designated router on this network

 

Tipe network-nya ternyata non-broadcast, OSPF menggunakan multicast untuk mencari neighbor untuk ini kita harus mengubah tipe network menjadi broadcast di masing-masing router.

R1(config)#int s0/0
R1(config-if)#ip ospf network broadcast
R2(config)#int s0/0
R2(config-if)#ip ospf network broadcast
R3(config)#int s0/0
R3(config-if)#ip ospf network broadcast

 

Tunggu sampai muncul notifikasi neighbor.

R1(config-if)#
*Mar 1 01:35:36.203: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial0/0 from LOADING to FULL, Loading Done
*Mar 1 01:35:38.451: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0 from LOADING to FULL, Loading Done

 

Sekarang mari kita cek lagi status neighbor.

R1#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 1 FULL/DROTHER 00:00:32 123.123.123.2 Serial0/0
3.3.3.3 1 FULL/DR 00:00:39 123.123.123.3 Serial0/0

 

Dari informasi di atas kita melihat bahwa R3 menjadi DR untuk area 0. Pada topologi hub and spoke, DR harus dimiliki oleh hub yaitu R1. Kita bisa mengubah DR menggunakan perintah ip ospf priority, dimana 255 adalah prioritas paling tinggi dan 0 berarti router tidak akan ikut serta pada pemilihan DR/BDR.

R1(config)#int s0/0
R1(config-if)#ip ospf priority 255
R2(config)#int s0/0
R2(config-if)#ip ospf priority 0
R3(config)#int s0/0
R3(config-if)#ip ospf priority 0

 

Kita cek lagi status neighbor-nya.

R1#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/DROTHER 00:00:36 123.123.123.2 Serial0/0
3.3.3.3 0 FULL/DROTHER 00:00:35 123.123.123.3 Serial0/0
R2#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 255 FULL/DR 00:00:30 123.123.123.1 Serial0/0
R3#sh ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 255 FULL/DR 00:00:34 123.123.123.1 Serial0/0

 

Sepertinya semua sudah ok, mari kita cek route-nya.

R1#sh ip route
 1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
 2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 123.123.123.2, 00:02:15, Serial0/0
 3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 123.123.123.3, 00:05:46, Serial0/0
 123.0.0.0/24 is subnetted, 1 subnets
C 123.123.123.0 is directly connected, Serial0/0
R2#sh ip route
 1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 123.123.123.1, 00:02:13, Serial0/0
 2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
 3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/65] via 123.123.123.3, 00:02:13, Serial0/0
 123.0.0.0/24 is subnetted, 1 subnets
C 123.123.123.0 is directly connected, Serial0/0
R3#sh ip route
 1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 123.123.123.1, 00:05:37, Serial0/0
 2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/65] via 123.123.123.2, 00:02:01, Serial0/0
 3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
 123.0.0.0/24 is subnetted, 1 subnets
C 123.123.123.0 is directly connected, Serial0/0

 

Sepertinya ok juga, mari kita ping tiap loopback dari masing-masing router.

R1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/9/20 ms
R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/8 ms
R2#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R2#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R3#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/12 ms
R3#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

 

Kalau kita lihat informasi route di R2, next hop untuk 3.3.3.3 adalah 123.123.123.3, kita cek pemetaan dari frame relay.

R2#sh frame-relay map
Serial0/0 (up): ip 123.123.123.1 dlci 201(0xC9,0x3090), dynamic,
 broadcast,, status defined, active
R2#ping 123.123.123.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R3#sh frame-relay map
Serial0/0 (up): ip 123.123.123.1 dlci 301(0x12D,0x48D0), dynamic,
 broadcast,, status defined, active
R3#ping 123.123.123.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

 

Hanya IP serial R1 yang dikenali oleh R2 dan R3 sehingga kita harus tambahkan frame relay map antara R2 dan R3.

R2(config)#int s0/0
R2(config-if)#frame-relay map ip 123.123.123.3 201
R3(config)#int s0/0
R3(config-if)#frame-relay map ip 123.123.123.2 301

 

Sekarang mari kita ping kembali.

R2#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
R3#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

 

OSPF dengan IPv6

Sekarang kita akan menambahkan IPv6 ke topologi sebelumnya dan tidak perlu menghapus konfigurasi IPv4. Implementasi ini biasa disebut Dual-Stack IPv4 dan IPv6 untuk transisi dari IPv4 ke IPv6.

Konfigurasi R1:

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 1::1/128
 ipv6 ospf 1 area 0
!
interface Serial0/0
 ipv6 address FE80::1 link-local
 ipv6 address 123::1/64
 ipv6 ospf network broadcast
 ipv6 ospf priority 255
 ipv6 ospf 1 area 0
!
ipv6 router ospf 1
 router-id 1.1.1.1

 

Konfigurasi R2:

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 2::2/128
 ipv6 ospf 1 area 0
!
interface Serial0/0
 ipv6 address FE80::2 link-local
 ipv6 address 123::2/64
 ipv6 ospf network broadcast
 ipv6 ospf priority 255
 ipv6 ospf 1 area 0
!
ipv6 router ospf 1
 router-id 2.2.2.2

 

Konfigurasi R3:

ipv6 unicast-routing
!
interface Loopback0
 ipv6 address 3::3/128
 ipv6 ospf 1 area 0
!
interface Serial0/0
 ipv6 address FE80::3 link-local
 ipv6 address 123::3/64
 ipv6 ospf network broadcast
 ipv6 ospf priority 255
 ipv6 ospf 1 area 0
!
ipv6 router ospf 1
 router-id 3.3.3.3

 

Kalau kita lihat di atas ada dua IPv6 yang dikonfigurasi yaitu alamat link-local dan global unicast. Frame relay dan OSPF menggunakan link-local untuk berkomunikasi antar router. Pada topologi di atas alamat link-local tidak dapat digunakan untuk berkomunikasi dengan loopback, karena loopback menggunakan alamat global unicast maka diperlukan alamat global unicast untuk saling berkomunikasi. Kita lihat konfigurasi OSPF di interface s0/0.

R1#sh ipv6 ospf int s0/0
Serial0/0 is up, line protocol is up
 Link Local Address FE80::1, Interface ID 6
 Area 0, Process ID 1, Instance ID 0, Router ID 1.1.1.1
 Network Type BROADCAST, Cost: 64
 Transmit Delay is 1 sec, State DR, Priority 255
 Designated Router (ID) 1.1.1.1, local address FE80::1

 

Kita lihat status neighbor.

R1#sh ipv6 ospf neighbor
R1#

 

Ternyata belum ada neighbor, di sini kita harus menambahkan frame relay map untuk alamat link-local dan global unicast.

Di R1

interface Serial0/0
 frame-relay map ipv6 FE80::2 102 broadcast
 frame-relay map ipv6 123::2 102
 frame-relay map ipv6 FE80::3 103 broadcast
 frame-relay map ipv6 123::3 103

 

Di R2

interface Serial0/0
 frame-relay map ipv6 FE80::1 201 broadcast
 frame-relay map ipv6 123::1 201
 frame-relay map ipv6 FE80::3 201
 frame-relay map ipv6 123::3 201

 

Di R3

interface Serial0/0
 frame-relay map ipv6 FE80::1 301 broadcast
 frame-relay map ipv6 123::1 301
 frame-relay map ipv6 FE80::2 301
 frame-relay map ipv6 123::2 301

 

Sekarang kita cek lagi status neighbor-nya.

R1#sh ipv6 ospf neighbor
Neighbor ID Pri State Dead Time Interface ID Interface
3.3.3.3 255 FULL/DR 00:00:34 6 Serial0/0
2.2.2.2 255 FULL/DROTHER 00:00:38 6 Serial0/0

 

Ternyata R1 belum menjadi DR, kita tambahkan kembali ipv6 ospf priority.

R1(config)#int s0/0
R1(config-if)# ipv6 ospf priority 255
R2(config-if)#int s0/0
R2(config-if)#ipv6 ospf priority 0
R3(config-if)#int s0/0
R3(config-if)#ipv6 ospf priority 0

 

Lalu kita cek hasilnya.

R1#sh ipv6 ospf neighbor
Neighbor ID Pri State Dead Time Interface ID Interface
3.3.3.3 0 FULL/DROTHER 00:00:31 6 Serial0/0
2.2.2.2 0 FULL/DROTHER 00:00:33 6 Serial0/0
R2#sh ipv6 ospf neighbor
Neighbor ID Pri State Dead Time Interface ID Interface
1.1.1.1 255 FULL/DR 00:00:37 6 Serial0/0
R3#sh ipv6 ospf neighbor
Neighbor ID Pri State Dead Time Interface ID Interface
1.1.1.1 255 FULL/DR 00:00:32 6 Serial0/0

 

Sekarang mari kita ping.

R1#ping 2::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/4 ms
R1#ping 3::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/4 ms
R2#ping 1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/2/4 ms
R2#ping 3::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/3/4 ms
R3#ping 1::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/4 ms
R3#ping 2::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

 

Sekarang kita punya topologi yang menjalankan IPv4 dan IPv6 secara bersamaan.

Advertisements

CCIE Bootcamp: RIP dan EIGRP

Hari ke-2 dibahas tentang RIP dan EIGRP, untuk tulisan blog kali ini saya hanya ambil dua kasus masing-masing satu untuk RIP dan EIGRP.

RIP: Split Horizon
Split horizon adalah suatu metoda untuk menghindari routing loops, mekanismenya dengan menolak mengirim route kembali melalui interface tempat route tersebut diterima. Contohnya apabila route 10.0.0.0/8 diterima melalui interface Fa0/0 maka split horizon tidak akan mengirim kembali route 10.0.0.0/8 tersebut melalui interface Fa0/0

Pada hub and spoke dengan routing RIP, split horizon akan menjadi masalah karena informasi route dari satu spoke tidak akan diteruskan ke spoke yang lain. Solusi untuk mengatasi ini ada dua, yaitu: disable split horizon dan konfigurasi hub sebagai point to point. Kita lihat pada gambar, R1 berfungsi sebagai hub, R2 dan R3 sebagai spoke.

Solusi 1: Disable Split Horizon

Konfigurasi FRSW:

frame-relay switching
!
interface Serial0/0
 description "To R2"
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0/2 102
!
interface Serial0/1
 description "To R3"
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 301 interface Serial0/2 103
!
interface Serial0/2
 description "To R1"
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/0 201
 frame-relay route 103 interface Serial0/1 301

 

Konfigurasi R1:

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.123 multipoint
 ip address 123.123.123.1 255.255.255.0
 frame-relay map ip 123.123.123.3 103 broadcast
 frame-relay map ip 123.123.123.2 102 broadcast
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

 

Konfigurasi R2:

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
 ip address 123.123.123.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 123.123.123.3 201
 frame-relay map ip 123.123.123.1 201 broadcast
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

 

Konfigurasi R3:

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
 ip address 123.123.123.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 123.123.123.2 301
 frame-relay map ip 123.123.123.1 301 broadcast
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

 

Mari kita cek melalui perintah sh ip route rip.

R1#sh ip route rip
     1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R       1.0.0.0/8 [120/2] via 123.123.123.3, 00:02:05, Serial0/0.123
                  [120/2] via 123.123.123.2, 00:01:52, Serial0/0.123
     2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R       2.2.2.2/32 [120/1] via 123.123.123.2, 00:00:24, Serial0/0.123
R       2.0.0.0/8 [120/1] via 123.123.123.2, 00:01:52, Serial0/0.123
     3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R       3.3.3.3/32 [120/1] via 123.123.123.3, 00:00:10, Serial0/0.123
R       3.0.0.0/8 [120/1] via 123.123.123.3, 00:02:05, Serial0/0.123

 

Sepertinya tidak ada masalah pada R1, semua route interface loopback diterima. Selanjutnya kita cek pada R2 dan R3.

R2#sh ip route rip
     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 123.123.123.1, 00:00:08, Serial0/0
R3#sh ip route rip
     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 123.123.123.1, 00:00:06, Serial0/0

 

Kita lihat di sini R2 dan R3 tidak menerima route dari masing-masing interface loopback. Sekarang mari kita disable split horizon di interface multipoint di R1.

R1(config)#int s0/0.123
R1(config-subif)#no ip split-horizon

 

Tunggu sebentar dan cek lagi informasi route di R2 dan R3

R2#sh ip route rip
     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 123.123.123.1, 00:00:03, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
R       3.3.3.3 [120/2] via 123.123.123.3, 00:00:03, Serial0/0

R3#sh ip route rip
     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 123.123.123.1, 00:00:01, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
R       2.2.2.2 [120/2] via 123.123.123.2, 00:00:01, Serial0/0

 

Lalu ping.

R2#ping 3.3.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/8 ms

 

Solusi 2: Konfigurasi Hub Sebagai Point to Point

Di sini kita akan mengubah interface multipoint di R1 menjadi point to point. Solusi ini membutuhkan pengubahan alamat IP di semua router.

Konfigurasi R1:

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.2 point-to-point
 ip address 12.12.12.1 255.255.255.0
 frame-relay interface-dlci 102
!
interface Serial0/0.3 point-to-point
 ip address 13.13.13.1 255.255.255.0
 frame-relay interface-dlci 103
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

 

Konfigurasi R2:

interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
 ip address 12.12.12.2 255.255.255.0
 encapsulation frame-relay
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

 

Konfigurasi R3:

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
 ip address 13.13.13.3 255.255.255.0
 encapsulation frame-relay
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

 

Mari kita cek.

R1#sh ip route rip
 2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 12.12.12.2, 00:00:16, Serial0/0.2
 3.0.0.0/32 is subnetted, 1 subnets
R 3.3.3.3 [120/1] via 13.13.13.3, 00:00:06, Serial0/0.3
R2#sh ip route rip
 1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 12.12.12.1, 00:00:03, Serial0/0
 3.0.0.0/32 is subnetted, 1 subnets
R 3.3.3.3 [120/2] via 12.12.12.1, 00:00:03, Serial0/0
 13.0.0.0/24 is subnetted, 1 subnets
R 13.13.13.0 [120/1] via 12.12.12.1, 00:00:03, Serial0/0
R3#sh ip route rip
 1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 13.13.13.1, 00:00:24, Serial0/0
 2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/2] via 13.13.13.1, 00:00:24, Serial0/0
 12.0.0.0/24 is subnetted, 1 subnets
R 12.12.12.0 [120/1] via 13.13.13.1, 00:00:24, Serial0/0

 

Dan ping.

R2#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/8 ms

 

EIGRP: Unequal Cost Load Balancing

Load balancing adalah kemampuan untuk mendistribusikan trafik melalui interface yang mempunyai suatu nilai yang sama ke tujuan. Di EIGRP nilai ini dapat diubah dengan mengubah parameter bandwidth dan delay. Mari kita lihat topologi dan konfigurasi berikut.

Konfigurasi R1

interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 13.13.13.1 255.255.255.0
!
router eigrp 10
 network 1.1.1.1 0.0.0.0
 network 12.12.12.1 0.0.0.0
 network 13.13.13.1 0.0.0.0
 no auto-summary

 

Konfigurasi R2

int Loopback0
 ip add 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.2 255.255.255.0
!
interface FastEthernet0/1
 ip address 24.24.24.2 255.255.255.0
!
router eigrp 10
 net 12.12.12.2 0.0.0.0
 net 2.2.2.2 0.0.0.0
 net 24.24.24.2 0.0.0.0
 no auto-summary

 

Konfigurasi R3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 13.13.13.3 255.255.255.0
!
interface FastEthernet0/1
 ip address 34.34.34.3 255.255.255.0
!
router eigrp 10
 network 3.3.3.3 0.0.0.0
 network 13.13.13.3 0.0.0.0
 network 34.34.34.3 0.0.0.0
 no auto-summary

 

Konfigurasi R4

interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 24.24.24.4 255.255.255.0
!
interface FastEthernet0/1
 ip address 34.34.34.4 255.255.255.0
!
router eigrp 10
 network 4.4.4.4 0.0.0.0
 network 24.24.24.4 0.0.0.0
 network 34.34.34.4 0.0.0.0
 no auto-summary

 

Apabila tidak ada perubahan apapun maka dari R1 menuju ke loopback R4 akan mempunyai dua jalur melalui R2 dan R3

R1#sh ip route eigrp
 34.0.0.0/24 is subnetted, 1 subnets
D 34.34.34.0 [90/307200] via 13.13.13.3, 00:00:22, FastEthernet0/1
 2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 12.12.12.2, 00:00:15, FastEthernet0/0
 3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 13.13.13.3, 00:00:14, FastEthernet0/1
 4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/435200] via 13.13.13.3, 00:00:13, FastEthernet0/1
 [90/435200] via 12.12.12.2, 00:00:13, FastEthernet0/0
 24.0.0.0/24 is subnetted, 1 subnets
D 24.24.24.0 [90/307200] via 12.12.12.2, 00:00:13, FastEthernet0/0
R1#sh ip route 4.4.4.4
Routing entry for 4.4.4.4/32
 Known via "eigrp 10", distance 90, metric 435200, type internal
 Redistributing via eigrp 10
 Last update from 12.12.12.2 on FastEthernet0/0, 00:03:57 ago
 Routing Descriptor Blocks:
 * 13.13.13.3, from 13.13.13.3, 00:03:57 ago, via FastEthernet0/1
 Route metric is 435200, traffic share count is 1
 Total delay is 7000 microseconds, minimum bandwidth is 10000 Kbit
 Reliability 255/255, minimum MTU 1500 bytes
 Loading 1/255, Hops 2
 12.12.12.2, from 12.12.12.2, 00:03:57 ago, via FastEthernet0/0
 Route metric is 435200, traffic share count is 1
 Total delay is 7000 microseconds, minimum bandwidth is 10000 Kbit
 Reliability 255/255, minimum MTU 1500 bytes
 Loading 1/255, Hops 2

 

Dalam hal ini yang terjadi adalah equal cost load balancing. Sekarang kita akan membagi trafik ke R4 dengan perbandingan 2:1, untuk setiap 2 paket dari R1 melewati R2 maka ada satu paket dari R1 melewati R3. Parameter yang akan kita ubah adalah bandwidth (K1) dan delay (K3) dengan nilai K lain adalah 0.

Bandwidth = 10^7 / minimum Bw kbps
Delay = delay in tens of microseconds
Metric = 256 x (Bandwidth + Delay)

Kalau kita membutuhkan perbandingan 2:1, maka kita harus mempunyai metric menuju R3 dua kali lebih besar yaitu 870400. Dengan rumus di atas maka akan kita dapatkan minimum Bw = 3703, silakan hitung sendiri darimana dapatnya 😀 Nilai ini kita masukan di interface Fa0/1 dengan perintah bandwidth.

R1(config)#int f0/1
 R1(config-if)#bandwidth 3703
 R1(config-if)#end

 

Kita hapus tabel routing

R1#clear ip route *

 

Lalu kita lihat nilai metric menuju R4

R1#sh ip eigrp topology 4.4.4.4/32
IP-EIGRP (AS 10): Topology entry for 4.4.4.4/32
 State is Passive, Query origin flag is 1, 1 Successor(s), FD is 435200
 Routing Descriptor Blocks:
 12.12.12.2 (FastEthernet0/0), from 12.12.12.2, Send flag is 0x0
 Composite metric is (435200/409600), Route is Internal
 Vector metric:
 Minimum bandwidth is 10000 Kbit
 Total delay is 7000 microseconds
 Reliability is 255/255
 Load is 1/255
 Minimum MTU is 1500
 Hop count is 2
 13.13.13.3 (FastEthernet0/1), from 13.13.13.3, Send flag is 0x0
 Composite metric is (870400/409600), Route is Internal
 Vector metric:
 Minimum bandwidth is 3703 Kbit
 Total delay is 7000 microseconds
 Reliability is 255/255
 Load is 1/255
 Minimum MTU is 1500
 Hop count is 2

 

Sekarang kita tambahkan perintah variance di EIGRP dengan nilai 2 (untuk perbandingan 2:1)

R1(config)#router eigrp 10
R1(config-router)#var
R1(config-router)#variance 2

 

Mari kita lihat lagi tabel routing untuk 4.4.4.4

R1#sh ip route 4.4.4.4
Routing entry for 4.4.4.4/32
 Known via "eigrp 10", distance 90, metric 435200, type internal
 Redistributing via eigrp 10
 Last update from 13.13.13.3 on FastEthernet0/1, 00:02:26 ago
 Routing Descriptor Blocks:
 13.13.13.3, from 13.13.13.3, 00:02:26 ago, via FastEthernet0/1
 Route metric is 870400, traffic share count is 1
 Total delay is 7000 microseconds, minimum bandwidth is 3703 Kbit
 Reliability 255/255, minimum MTU 1500 bytes
 Loading 1/255, Hops 2
 * 12.12.12.2, from 12.12.12.2, 00:02:26 ago, via FastEthernet0/0
 Route metric is 435200, traffic share count is 2
 Total delay is 7000 microseconds, minimum bandwidth is 10000 Kbit
 Reliability 255/255, minimum MTU 1500 bytes
 Loading 1/255, Hops 2

 

Di sini kita lihat sekarang trafik terbagi menjadi 2:1 untuk R2:R3.

CCIE Bootcamp: Frame Relay

Tulisan ini merupakan rangkaian blog dari CCIE Bootcamp 9 hari yang diadakan oleh ID Networkers (bukan iklan loh!). Tulisan ini merupakan ringkasan dari materi yang penulis dapatkan pada hari sebelumnya dan untuk hari pertama membahas tentang Frame Relay.

Frame Relay adalah teknologi untuk menghubungkan perangkat dalam wide area network (WAN) menggunakan metode packet switching dan bekerja di physical dan data link layer pada OSI layers. Sebelum Frame Relay dapat mengirimkan paket data, Frame Relay membutuhkan informasi yang memetakan antara alamat data link layer (L2) dan network layer (L3). Ada dua metoda untuk pemetaan ini yaitu pemetaan secara dinamis maupun statis (dynamic and static mapping). Pemetaan secara dinamis bergantung pada Frame Relay Inverse Address Resolution Protocol (Inverse ARP) untuk menentukan alamat tujuan berdasarkan DLCI.

Untuk menghubungkan dua router menggunakan Frame Relay kita dapat menggunakan Frame Relay Switch, walaupun kita dapat menggunakan koneksi back to back tapi untuk kasus ini kita akan menggunakan Frame Relay Switch.

Frame Relay Topology

Konfigurasi Frame Relay Switch:

frame-relay switching
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/1 201
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0/0 102

 

Dynamic Mapping
Dengan pemetaan dinamis kita cukup memberikan alamat IP dan set enkapsulasi interface sebagai Frame Relay.

Konfigurasi R1:

interface Serial0/0
 ip address 12.12.12.1 255.255.255.0
 encapsulation frame-relay

 

Static Mapping
Pemetaan dengan Inverse ARP akan di-override oleh pemetaan statis.

Konfigurasi R2:

interface Serial0/0
 ip address 12.12.12.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 12.12.12.1 201 broadcast

 

Parameter broadcast di atas berguna untuk melewatkan paket multicast yang digunakan oleh routing protocol.

 

Frame Relay pada Sub Interface
Selain pada interface utama, Frame Relay juga dapat digunakan pada sub interface.

Konfigurasi Frame Relay pada sub interface:

Dynamic Mapping (R1)

interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 multipoint
 ip address 12.12.12.1 255.255.255.0
 frame-relay interface-dlci 102

 

Static Mapping (R2)

interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 multipoint
 ip address 12.12.12.2 255.255.255.0
 frame-relay map ip 12.12.12.1 201 broadcast

 

Kita dapat menggunakan kombinasi pemetaan dinamis dan statis untuk tiap router.
Pada sub interface ada dua mode yang dapat digunakan, dengan mode multipoint dan point to point.

Catatan: Dengan mode point to point kita tidak dapat menggunakan static mapping.

R1(config-subif)#frame-relay map ip 12.12.12.2 102 broadcast
 Only frame-relay interface-dlci command should beused on point-to-point interfaces not frame-relay map

 

Tips: Kita tidak dapat mengubah secara langsung dari mode multipoint ke point to point, untuk ini kita bisa menggunakan perintah default. Jangan lupa untuk mencatat konfigurasi sebelumnya!

R1(config)#int s0/0.1 point-to-point
% Warning: cannot change link type

R1(config)#default interface s0/0
Building configuration...
Interface Serial0/0 set to default configuration

 

Konfigurasi Frame Relay pada sub interface dengan mode point to point di R1:

interface Serial0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 12.12.12.1 255.255.255.0
 frame-relay interface-dlci 102

 

Verifikasi
Untuk memastikan kalau Frame Relay sudah berjalan kita bisa menggunakan perintah show frame-relay map atau show frame-relay pvc.

R1#sh frame-relay map
Serial0/0 (up): ip 12.12.12.2 dlci 102(0x66,0x1860), dynamic,
 broadcast,, status defined, active

R1#sh frame-relay pvc
PVC Statistics for interface Serial0/0 (Frame Relay DTE)
Active Inactive Deleted Static
 Local 1 0 0 0
 Switched 0 0 0 0
 Unused 0 0 0 0
DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0
input pkts 1 output pkts 1 in bytes 34
 out bytes 34 dropped pkts 0 in pkts dropped 0
 out pkts dropped 0 out bytes dropped 0
 in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
 out BECN pkts 0 in DE pkts 0 out DE pkts 0
 out bcast pkts 1 out bcast bytes 34
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
 pvc create time 00:00:57, last time pvc status changed 00:00:47

 

Dan tentu saja ping 😀

R1#ping 12.12.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/16 ms

Galaxy 5: Upgrade ke Eclair atau Froyo?

Apabila anda ingin upgrade Samsung Galaxy 5 i5500 (G5), anda mempunyai dua pilihan yaitu upgrade firmware ke Eclair versi Eropa atau Froyo versi Amerika Latin. Firmware versi Asia yang dulu saya pakai ada masalah di lock GPS, tapi sudah ada solusinya di sini, dan masalah suka hang. Saat ini saya sendiri pakai firmware Eclair versi Eropa dengan solusi lock GPS, akan saya jelaskan apa kelebihan dan kekurangan firmware Eclair dan Froyo.

Eclair versi Eropa, masalah lock GPS masih muncul di firmware ini, tapi bisa memakai solusi di atas. Masalah suka hang tidak pernah terjadi lagi di firmware ini.

Froyo versi Amerika Latin, semua masalah di atas sudah tidak muncul, tetapi muncul masalah baru di baterai yang cukup boros dan kompas yang kacau. Apabila kita berputar ke kanan, maka kompas akan berputar ke kiri, demikian juga sebaliknya, dan bila kita mengarah ke utara maka kompas akan mengarah ke arah yang lain. Sampai saat ini baru masalah baterai yang sudah ada solusinya, mungkin akan saya tulis lain waktu, tetapi untuk kompas belum ada solusinya.

Sekarang terserah anda untuk memilih upgrade ke versi apa, selanjutnya apa saja yang dibutuhkan untuk upgrade firmware.

Yang kita butuhkan adalah program Samsung Kies, program Odin, file OPS, dan tentu saja firmware-nya. Kecuali Samsung Kies, anda dapat mengunduh semuanya di samfirmware.com. Pilih salah satu dari firmware di bawah ini:

  • Eclair: I5500XWJK3
  • Froyo: I5500LUYJP2

Gunakan winrar untuk mengekstrak file firmware yang berekstensi rar. Anda akan mendapatkan file TAR(JK3).tar untuk Eclair atau I5500LAROJP2.tar untuk Froyo.

Kalau semua bahan sudah lengkap, mari kita lanjutkan dengan caranya:

  1. Windows XP, karena saya pakai ini dan tidak ada masalah. *belum nemu caranya untuk linux*
  2. Install Samsung Kies lalu jalankan programnya, program ini diperlukan agar G5 terdeteksi oleh komputer. Sambungkan G5 dengan kabel data ke komputer dan pastikan icon G5 muncul.
  3. Mumpung sekalian buka Samsung Kies, mari kita melakukan backup mulai dari kontak, kalendar, dll. File di SD card tidak perlu di-backup.
  4. Setelah proses backup selesai, matikan Samsung Kies, cabut kabel data, matikan G5, keluarkan simcard dan SD card. Sebenarnya ada aturan untuk mencabut baterai selama 5 detik, tapi dengan mengeluarkan simcard saja sepertinya sudah lebih dari 5 detik 😀
  5. Masuk ke Download Mode dengan menekan tombol volume down di sebelah kiri, tombol yang di tengah dan tombol power secara bersamaan. Bisa dengan tekan dan tahan tombol volume down terlebih dahulu, lanjut dengan tombol yang di tengah lalu tombol power. Kalau benar akan muncul tampilan seperti pada gambar.
  6. Jalankan program Odin, sambungkan G5 dengan kabel data ke komputer, (1) centang opsi One Package, (2) klik OPS lalu pilih file EUROPA_v1.0.ops, (3) klik One Package lalu pilih TAR(JK3).tar (Eclair) atau I5500LAROJP2.tar (Froyo).
  7. Klik tombol Start, dan tunggu sampai 5 menit. Sebenarnya dalam waktu kurang lebih 3 menit proses flash sudah selesai, dan G5 akan reboot sendiri. Biasanya saya menunggu sampai sekitar 5 menit 10 detik hingga di kolom kiri atas muncul tulisan PASS dengan background hijau, lalu cabut G5 dari kabel data.
  8. Lakukan hard reset dengan menekan tombol *2767*3855#
  9. Matikan G5, masukkan kembali simcard dan SD card, nyalakan dan selamat meng-install ulang aplikasi juga setting ulang konfigurasi. Untuk memudahkan setting APN gunakan Asisten APN (beta) dari Market

Selamat mencoba!

Hemat baterai Android dengan ShutUpBatterySaver

Masalah paling besar smartphone Android adalah baterainya yang cukup boros! Dulu saya memakai Juice Defender agar lebih hemat, ternyata aplikasi Google Talk saya tidak jalan walaupun sudah di-exclude di konfigurasinya. Akhirnya Juice Defender pun saya uninstall.

Dari situs XDA Setelah mencari informasi baterai yang boros, ternyata salah satu masalah ada di fitur AutoSync. Aplikasi ShutUpBatterySaver akan mengaktifkan fitur AutoSync pada waktu tertentu. Misalnya setiap 1 jam, AutoSync akan aktif selama 3 menit. Efek dari aplikasi ini adalah tidak adanya real-time push mail. Apabila anda ingin mendapat email secepat mungkin, sebaiknya tidak menggunakan aplikasi ini.

Selain mengatur fitur AutoSync, aplikasi ini dapat mematikan koneksi Internet apabila sinyal mencapai titik tertentu tapi saya tidak mengaktifkan fitur ini.

Dengan kondisi AutoSync aktif 3 menit setiap 1 jam, baterai saya dapat bertahan pada kondisi 50% setelah 12 jam dengan pemakaian yang cukup aktif.

Galaxy 5: GPS fix di Eclair

GPS fix untuk Samsung Galaxy 5 (i5500) dengan firmware Eclair

Samsung Galaxy 5 (i5500) yang saya gunakan sangat susah untuk lock GPS, bahkan pada saat di luar ruangan. Di beberapa forum menyarankan untuk mengganti parameter di /data/gps/secgps.conf, tapi solusi ini tidak mengatasi masalah. Ternyata masalah ini dapat diatasi dengan menekan kode *#*#1472365#*#* atau menggunakan aplikasi GPS optimisation. Sayangnya solusi ini tidak permanen, karena harus diaktifkan setiap kali ingin menggunakan GPS.

Sekarang sudah ada solusi lain dari Forum XDA dengan mengubah parameter di GPS Setup. Setelah saya coba sekitar seminggu, saya selalu mendapat GPS fix di luar ruangan.

GPS Setup dapat diakses dengan menekan *#*#1472365#*#* pada menu dialer

Apabila GPS belum diaktifkan, akan muncul peringatan untuk mengaktifkan GPS

Apabila GPS sudah diaktifkan, akan muncul menu GPS Setup

Pilih menu SettingsParameter SettingsPosition mode, ubah menjadi option 3

Pilih menu SettingsFix Request SettingsSession Operation, ubah menjadi Standalone

Pilih menu SettingsFix Request SettingsServer Option, ubah menjadi Local

Pilih menu gpsOne XTRAXtra Enable, ubah menjadi Enable

Sekarang coba cek apakah anda bisa lock GPS? Salah satu aplikasi untuk mengecek sinyal satelit adalah GPS Status. Masalah GPS ini tidak muncul di Froyo, tapi ada masalah lain di kompas 😀

One IOS to Rule Them All!

Tanggal 12 Januari 2010 adalah hari terakhir Cisco IOS versi 12.4 dapat dibeli, penggantinya adalah Cisco IOS versi 15.0. Bagi yang memiliki service contract masih mendapat support hingga 31 Januari 2016, selengkapnya silakan lihat di link ini.

End-of-Life Milestones and Dates for the Cisco IOS Software Release 12.4

One IOS to rule them all!
Dulu, kita perlu mengunduh IOS sesuai dengan fitur yang kita inginkan, sekarang kita hanya perlu mengunduh satu IOS untuk semua fitur.

Lisensi
Cisco IOS versi 15.0 menggunakan sistem lisensi agar bisa menggunakan fitur yang lebih advanced.  Bagi yang pernah menggunakan Cisco ASA, mungkin sudah mengenal cara menambah lisensi ini.

Apabila kita ingin meng-upgrade fiturnya, kita harus membeli lisensi untuk fitur yang diinginkan. Cisco akan mengirim Product Activation Key (PAK), PAK ini kita daftarkan ke situs Cisco untuk mendapatkan activation key. Activation key ini digunakan untuk mengaktifkan fitur yang diinginkan.

Cara mengaktifkan fiturnya dapat dilihat di sini.

Bagaimana dengan perusahaan yang mempunyai banyak perangkat Cisco yang perlu diatur? Masalah ini dapat diatasi menggunakan Cisco License Manager, software ini dapat diunduh bagi mereka yang mempunyai service contract dengan Cisco.